<br><br><div class="gmail_quote">On Sat, May 26, 2012 at 1:46 PM, Marius Tibeica <span dir="ltr"><<a href="mailto:mtibeica@gmail.com" target="_blank">mtibeica@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Thanks for all the suggestion. <div>I will try to implement them as soon as I can and come back with an email about what I did.<br></div></blockquote><div><br>Re latest commits...<br><br>AsyncOp::AsyncOp still checks mBusy and throws; can be removed<br>
<br>DECLARE_POOLS <br> maybe we should call it DECLARE_UTILS or similar?<br> at least two function calls are missing spaces after commas!<br> write var = value, not var=value<br> if (error) is preferred vs if (error != NULL)<br>
maybe do_all should be called start or invoke?<br> do_all: if (aError) Local<String> aErrorStr = String::New(aError->get_msg().c_str()); delete ...; throw ...;<br> maybe we should move mBusy = true/false from AsyncOp to _all & _pool<br>
did you test the conditions that throw? (busy and xapian error)<br><br>binding.cc<br> I think kBusyMsg = ... probably belongs in init() (you do need the definition at top of file tho)<br> can remove the commented out tryCallCatch & GetInstance<br>
<br>enquire.cc<br> GetMset() spaces around !=<br> arguments error msg: "arguments are (number, number, [function])"<br> _convert doesn't need if(data) before delete data<br><br></div></div>