<br><br><div class="gmail_quote">On Sat, Jun 9, 2012 at 12:56 AM, Marius Tibeica <span dir="ltr">&lt;<a href="mailto:mtibeica@gmail.com" target="_blank">mtibeica@gmail.com</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div class="gmail_quote"><blockquote class="gmail_quote" style="margin:0pt 0pt 0pt 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">...<div><div>Since we only have one emit in the existing binding, we decided to change that to a callback as events are not necessarily required, so these changes are not required yet.</div>



<div><br></div>
</div></blockquote></div><br>Done. Also updated quickstart.js and quickstartsync.js to reflect the changes.<br></blockquote><div><br>Re latest commits...<br><br>WritableDatabase::ReplaceDocument()<br>  might providing an empty term string &#39;&#39; be valid? if not, maybe we should let Xapian throw an error? <br>

<br>There are some missing spaces after commas and comparison operators (-.-)<br><br>You use unsigned in query.cc:Parse() -- could those be Xapian or V8 types?<br><br>Query::Query should take const Xapian::Query&amp;, if not a * type<br>

<br>For simple switch stmts i&#39;ll style it this way for readability:<br><span style="font-family:courier new,monospace">  switch(value) {</span><br style="font-family:courier new,monospace"><span style="font-family:courier new,monospace">  case a: one or two stmts; break;</span><br style="font-family:courier new,monospace">
<span style="font-family:courier new,monospace">  case b: alt stmt;         break;</span><br style="font-family:courier new,monospace"><span style="font-family:courier new,monospace">  }</span><br><br><br></div></div>