[Xapian-discuss] Argument isn't numeric in subroutine entry ? Any ideas please...

Joss Shaw jossblowing at yahoo.co.uk
Thu Oct 11 18:05:30 BST 2007

Hey all !

I'm getting a really strange thing happening in some code that once worked with an older version of Xapian < 1.0 and that now seems "broken" in 1.2.0.

Basically if I do...

my @my_terms = qw/query here/;
my $xapian_query = Search::Xapian::Query->new(OP_OR, @my_terms);

my @my_terms2 = qw/nuts beer/;
my $xapian_query2 = Search::Xapian::Query->new(OP_OR, @my_terms);

and then finally:

my $final_query = Search::Xapian::Query(OP_AND, ($xapian_query, $xapian_query2));

It will throw an error like: 

Argument "Xapian::Query(((query OR here) AND (nuts OR beer)))" isn't numeric in subroutine entry at /perl/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/Search/Xapian/Enquire.pm line 42.

I'm sure it once worked... hopefully you guys can make out what I'm trying to achieve - any pointers warmly welcomed.
Many many thanks,

Yahoo! Answers - Got a question? Someone out there knows the answer. Try it

More information about the Xapian-discuss mailing list