[Xapian-discuss] Failing to build PHP Bindings OSX 10.6

James Aylett james-xapian at tartarus.org
Thu Dec 16 21:54:04 GMT 2010


On 16 Dec 2010, at 13:39, John Wards wrote:

> Very odd this, I have downloaded the latest xapian-core and bindings.
> Installed xapian-core no problem in /usr/local/xapian
> 
> However I am getting very strange errors when running make when trying
> to install the PHP bindings, it configures fine.
> 
> Paste bin here:
> http://pastebin.com/JWViJz4b
> 
> I am missing something obvious I know...
> 
> I have built 1.0 on this machine in the past fine...


Looks to me like 1.0 is still installed, in /opt/local, and that's what's being picked up when building. See line 136, for instance: -I/opt/local/include is on the command line ahead of -I/usr/local/xapian/include, and there's a Xapian in there, which you can see at line 1162, for instance. You may have to wipe out the older xapian to build this, or you may be able to set CFLAGS=-I/usr/local/xapian/include (which might get used earlier in building the compile command; I don't know).

Olly & Richard, could configure could check this situation by importing xapian/version.h and checking XAPIAN_VERSION, major_version or something? configure will check the version of xapian-config, but that's not quite the same if your include paths get contaminated…

J

-- 
 James Aylett
 talktorex.co.uk - xapian.org - devfort.com - spacelog.org






More information about the Xapian-discuss mailing list