[Xapian-devel] error building xapian

Alex Deucher alexdeucher at gmail.com
Mon Aug 22 22:08:47 BST 2005

On 8/20/05, Olly Betts <olly at survex.com> wrote:
> On Fri, Aug 12, 2005 at 02:12:47PM -0400, Alex Deucher wrote:
> > I'm getting the following error when trying to build xapian.  I've
> > tried versions 0.9.1 and 0.9.2, same error.  It's a x86 debian box,
> > gcc 4.0.1.  It builds fine on my gentoo amd64 box (gcc 3.4.3).
> I can't really see how the processor or distro makes a difference, so
> I bet it's GCC 4.0.1 being fussier about not accepting C++ code which
> doesn't quite follow the standard.  Oddly I've successfully built with
> GCC4 pre-release snapshots, but perhaps this was changed not long before
> release.
> A quick look suggests that InMemoryDatabase isn't being forward declared.
> I won't have access to a box with GCC4 on for a couple of weeks, but you
> could try adding "class InMemoryDatabase;" at (say) line 123 of
> inmemory_database.h.  And similarly for any other classes which cause
> similar errors.
> If that fixes it, a patch showing the changes required would be most
> appreciated.


class InMemoryDatabase;

at line 123 of inmemory_database.h fixed the problem.



> Cheers,
>     Olly

More information about the Xapian-devel mailing list