[Xapian-devel] GSoC xapian node binding
xapian at networkimprov.net
Fri May 25 01:08:29 BST 2012
On Wed, May 23, 2012 at 1:35 PM, Liam <xapian at networkimprov.net> wrote:
> On Tue, May 22, 2012 at 8:12 PM, Liam <xapian at networkimprov.net> wrote:
>> Re latest code...
> Few more notes...
And a few more!
Use "that" instead of "pThis" as the name for the unwrapped args.This()
There are currently tests for mBusy in both _do_async and AsyncOp::AsyncOp.
We can remove the latter, and also make AsyncOp::AsyncOp take the unwrapped
object, rather than do the unwrap itself.
Use "Type aVar = value;" where possible, since we're removing try blocks
that required separate "Type aVar;".
The data argument for the _do functions should be named "data" vs "aData".
Could the DECLARE_POOL methods be defined once per class if the _process &
_convert functions are passed as args to the _do functions and then stored
in the AsyncOp object?
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Xapian-devel