[Xapian-devel] GSoC xapian node binding

Liam xapian at networkimprov.net
Mon May 28 19:33:02 BST 2012


On Sat, May 26, 2012 at 1:46 PM, Marius Tibeica <mtibeica at gmail.com> wrote:

> Thanks for all the suggestion.
> I will try to implement them as soon as I can and come back with an email
> about what I did.
>

Re latest commits...

AsyncOp::AsyncOp still checks mBusy and throws; can be removed

DECLARE_POOLS
  maybe we should call it DECLARE_UTILS or similar?
  at least two function calls are missing spaces after commas!
  write var = value, not var=value
  if (error) is preferred vs if (error != NULL)
  maybe do_all should be called start or invoke?
  do_all: if (aError) Local<String> aErrorStr =
String::New(aError->get_msg().c_str()); delete ...; throw ...;
  maybe we should move mBusy = true/false from AsyncOp to _all & _pool
  did you test the conditions that throw? (busy and xapian error)

binding.cc
  I think kBusyMsg = ... probably belongs in init() (you do need the
definition at top of file tho)
  can remove the commented out tryCallCatch & GetInstance

enquire.cc
  GetMset() spaces around !=
  arguments error msg: "arguments are (number, number, [function])"
  _convert doesn't need if(data) before delete data
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.xapian.org/pipermail/xapian-devel/attachments/20120528/4d8a29a9/attachment.htm>


More information about the Xapian-devel mailing list