[Xapian-discuss] Building Xapian and Python Bindings for Windows: Solved

Olly Betts olly at survex.com
Tue Dec 27 23:37:40 GMT 2005

On Wed, Dec 28, 2005 at 12:20:01AM +0100, Patrick M?zard wrote:
> Well, I hit something which was solved by the very same solution. I am 
> not sure both issues are related but it is likely they are: it seems 
> some dependent source is added in one case and not in the other, the 
> source being a directory instead of a file (the dependency is for an 
> archive dependency generation action or something like that). find.exe 
> was a good suspect. Here is the trace I have if I move the bin/ includes 
> after the system ones:

The trace makes me suspect a problem in libtool, and looking at the
libtool code it uses find when linking objects from archives in certain
cases.  It's hard to see whether this case is used on cygwin, but I
suspect it is.

I'll point out this issue to the libtool developers, but it looks like
setting PATH suitably is indeed currently required to work around this.


More information about the Xapian-discuss mailing list