[Xapian-discuss] Building Xapian and Python Bindings for Windows: Solved

Patrick Mézard pmezard at gmail.com
Tue Dec 27 23:20:01 GMT 2005

Olly Betts a écrit :

>On Tue, Dec 27, 2005 at 10:55:52PM +0100, Patrick M?zard wrote:
>>The following posts where especially useful:
>>- http://thread.gmane.org/gmane.comp.search.xapian.general/1645 : 
>>win32/find.exe vs unix/find
>That should no longer be an issue in 0.9.2 - I redid the code which used
>find and it now looks at the contents of the Makefile.am-s instead.
>Did you actually hit this issue (in which case something's amiss)?  Or
>did you just read about it and take steps to avoid it?
Well, I hit something which was solved by the very same solution. I am 
not sure both issues are related but it is likely they are: it seems 
some dependent source is added in one case and not in the other, the 
source being a directory instead of a file (the dependency is for an 
archive dependency generation action or something like that). find.exe 
was a good suspect. Here is the trace I have if I move the bin/ includes 
after the system ones:
Making all in .
make[3]: Entering directory `/c/dev/mz/xapian/xapian-core-0.9.2/backends'
/bin/sh ../libtool --tag=CXX --mode=link g++ -Wall -W -Wredundant-decls 
-Wundef -Wpointer-arith -Wcast-qual -Wcast-align -Wno-multichar 
-Wno-long-long -fno-gnu-keywords -g -O2   -o libbackend.la   
database.lo  quartz/libquartz.la flint/libflint.la 
inmemory/libinmemory.la  multi/libmulti.la
rm -fr  .libs/libbackend.lax
rm -fr .libs/libbackend.lax
mkdir .libs/libbackend.lax
rm -fr .libs/libbackend.lax/libquartz.a
mkdir .libs/libbackend.lax/libquartz.a
(cd .libs/libbackend.lax/libquartz.a && ar x 
libtool: link: ERROR: object name conflicts: 
make[3]: *** [libbackend.la] Error 1
make[3]: Leaving directory `/c/dev/mz/xapian/xapian-core-0.9.2/backends'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/c/dev/mz/xapian/xapian-core-0.9.2/backends'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/c/dev/mz/xapian/xapian-core-0.9.2'
make: *** [all] Error 2

Patrick Mézard

More information about the Xapian-discuss mailing list