[Xapian-discuss] Building on Windows

Craig Lee Craig.Lee at noetix.com
Wed Jun 8 21:01:09 BST 2005

That did the trick.

- making sure that the 'find.exe' in cygwin was found first
- using --prefix and setting it to a directory without spaces

I then did a 'make distclean', re-ran './configure --prefix=/home/calee'
and then 'make' and it built!  I also ran 'make install' and then worked
as well.

Are there some tests I can run to certify that the build is OK?

Thanks so much, Olly, for the help.


-----Original Message-----
From: Olly Betts [mailto:olly at survex.com] 
Sent: Wednesday, June 08, 2005 12:28 PM
To: Craig Lee
Cc: xapian-discuss at lists.xapian.org
Subject: Re: [Xapian-discuss] Building on Windows

On Wed, Jun 08, 2005 at 11:40:27AM -0700, Craig Lee wrote:
> Excellent, that fixed the configure errors.  I just set my PATH to 
> just the cygwin\bin directory.  Thanks!

OK, I'll at least note this issue, and have a think about eliminating
the need to use find.

> I still get the build errors when I run 'make'.  How do I tell make to

> rebuild everything even if its built already?  (Please excuse my make
> ignorance)

If you're about to rerun configure, then this should restore the tree to
the state it was in when you unpacked the tarball:

make distclean

If you just want to clean up compiled object files and the like but keep
the effects of configure then use:

make clean


More information about the Xapian-discuss mailing list