[Xapian-discuss] xapian-compact 'undefined symbol' error

Olly Betts olly at survex.com
Fri Jul 31 03:31:08 BST 2009

On Thu, Jul 30, 2009 at 03:43:23PM -0400, Paul Williamson wrote:
> I'm attempting to merge two xapian databases using the xapian-compact
> command.  I've tried with some different combinations of -n and -b options
> and also with no options at all.  I keep getting the same error:
> postlist ...xapian-compact: symbol lookup error: xapian-compact: undefined
> symbol: _ZN10FlintTableC1ESsSsbib

This is a dynamic linking error, so command line options won't make much

It looks like I managed to break the library ABI in 1.0.13, but only for
a symbol used by xapian-compact (so this won't affect users of the
public API).

I think you'll only see this if you run xapian-compact from < 1.0.13 and
use libxapian15.so (or whatever it is named on your platform) from >=
1.0.13, or vice versa.  That would explain why nobody has noticed
before.  If that's not your situation, please say.

It's pretty easy to fix - I just need to undo this change, but leave a
copy of the new constructor in place so xapian-compact from 1.0.13 and
1.0.14 will still work with libxapian15.so 1.0.15 and later.

For anyone maintaining binary packages of Xapian, I'd recommend holding
off packaging 1.0.13 and 1.0.14 if you haven't already.


More information about the Xapian-discuss mailing list