Strange index consistency issue

Bob Cargill rsc.bioeng at
Sun Jan 10 02:53:14 GMT 2016

Olly Betts <olly <at>> writes:
> You could try:
> delve -t '' ./xapiandb
> That will list the document lengths, so you can see if document 6 is in
> that list or not.

I am the recoll user mentioned in the first post above. I still have a copy
of the (potentially) corrupted index and I did the requested testing. 

I ran delve -t '' ./xapiandb on the index and it returned a very long list
of document IDs, separated by spaces. I than ran delve -t '' ./xapiandb |
grep " 6 " and it returned nothing. 

So, document 6 was not in the list. 

There were other documents missing from the index as well, so I ran delve -t
'' ./xapiandb | head -c 100 
The first ID was 257, then it began sequentially from 356. Looks like the
first approximately 350 document IDs are "missing." 

I will look into the bug you listed to see if it might be related. If there
is anything else that I can do, please let me know. 

More information about the Xapian-discuss mailing list