[Xapian-discuss] xapian v0.9.10 vs v1.0.1

James Aylett james-xapian at tartarus.org
Fri Jun 22 07:32:29 BST 2007

On Thu, Jun 21, 2007 at 02:22:02PM +0000, - Tong - wrote:

> - I first compiled xapian/omega version 1.0.1 under Slackware, ie gcc v3.4.6.
>   omindex runs ok without parameters. But when used to build db. It
>   just hangs there. After break it out, I notice there is only one file
>   created in db, flintlock or something. It must has been stopped at the
>   locking stage.

Could you run strace(1) on it so we know what syscall it's hanging
during? That might help.

> - I then tried to compiled xapian/omega version 1.0.1 under Fedora
> Core 5, but the new code won't compile under gcc v4.1.1.

What's the compilation error? (The start of the error text is more
useful than the end; C++ errors can go on for a while...)

> - I then compiled xapian/omega version 0.9.10 in Fedora Core 5, where I
>   previously tested everything successfully. But after copying the binary
>   executables over to sf.net, omindex won't run, saying it can't find
>   libxapian.so.13.  The building procedure is exactly the same in Slackware
>   and FC5. So I gave this route up.

If you build using dynamic libraries, you will have to install the
dynamic libraries on any machine you want to use the executable
on. One way round this is to disable dynamic libraries when building
xapian-core, although I haven't tried this for a while.

> - Finally I compiled xapian/omega version 0.9.10 in Slackware, ie gcc v3.4.6.
>   This is the version that is running successfully on sf.net now.

My guess is that either sf.net already has the relevant libxapian.so
installed, or dynamic libraries are being disabled when you build on
Slackware for some reason.


  James Aylett                                                  xapian.org
  james at tartarus.org                               uncertaintydivision.org

More information about the Xapian-discuss mailing list