[Xapian-discuss] xapian v0.9.10 vs v1.0.1

Olly Betts olly at survex.com
Fri Jun 22 15:25:47 BST 2007

On Fri, Jun 22, 2007 at 07:32:29AM +0100, James Aylett wrote:
> On Thu, Jun 21, 2007 at 02:22:02PM +0000, - Tong - wrote:
> > - I first compiled xapian/omega version 1.0.1 under Slackware, ie gcc v3.4.6.
> >   omindex runs ok without parameters. But when used to build db. It
> >   just hangs there. After break it out, I notice there is only one file
> >   created in db, flintlock or something. It must has been stopped at the
> >   locking stage.
> Could you run strace(1) on it so we know what syscall it's hanging
> during? That might help.

If this is on SF, I imagine it's a badly configured NFS lockd.  Locking
never worked reliably on the compile farm NFS mounted home directories.

If so, I'm not really sure what to do to address this.  Filing a support
request with SF might help.

> > - I then tried to compiled xapian/omega version 1.0.1 under Fedora
> > Core 5, but the new code won't compile under gcc v4.1.1.
> What's the compilation error? (The start of the error text is more
> useful than the end; C++ errors can go on for a while...)

I'm using GCC 4.1.2 on Ubuntu, so I doubt it's related to the compiler
version, but it would be useful to know what the error is.

Compiling on one Linux distro and running on another is something of
a minefield, and often worse for C++.  It might be worth installing
"CentOS 4.4" (which is what the CF shell server seems to be running) and
using that to build.  If you use virtualisation software (KVM or 
similar) you can run it on top of your normal distro.


More information about the Xapian-discuss mailing list