[Xapian-discuss] Re: xapian v0.9.10 vs v1.0.1

- Tong - mlist4suntong at yahoo.com
Fri Jun 22 17:27:07 BST 2007

On Fri, 22 Jun 2007 15:25:47 +0100, Olly Betts wrote:

>> > - I first compiled xapian/omega version 1.0.1 under Slackware, ie gcc v3.4.6.
>> >   omindex runs ok without parameters. But when used to build db. It
>> >   just hangs there. After break it out, I notice there is only one file
>> >   created in db, flintlock or something. It must has been stopped at the
>> >   locking stage.
>> Could you run strace(1) on it so we know what syscall it's hanging
>> during? That might help.

That's what I first tried, but unfortunately SF doesn't offer strace.

> If this is on SF, I imagine it's a badly configured NFS lockd.  Locking
> never worked reliably on the compile farm NFS mounted home directories.
> If so, I'm not really sure what to do to address this.  Filing a support
> request with SF might help.

Since I get the v0.9.10 working, and I don't know what exactly the problem
is, I'd leave it to somebody who is more suitable. 
>> > - I then tried to compiled xapian/omega version 1.0.1 under Fedora
>> > Core 5, but the new code won't compile under gcc v4.1.1.
>> What's the compilation error? (The start of the error text is more
>> useful than the end; C++ errors can go on for a while...)
> I'm using GCC 4.1.2 on Ubuntu, so I doubt it's related to the compiler
> version, but it would be useful to know what the error is.

Ah,found it, not because of the gcc, but because of one illegal char:

xapian-omega-1.0.1$ make
make  all-am
make[1]: Entering directory `/home/volsunan/try/xapian-omega-1.0.1'
if g++ -DHAVE_CONFIG_H -I. -I. -I. -I./common -DCONFIGFILE_SYSTEM=\"/usr/local/etc/omega.conf\"  -Wall -W -Wredundant-decls -Wpointer-arith -Wcast-qual -Wcast-align -Wno-multichar -Wno-long-long -fno-gnu-keywords -Wundef -Wshadow -g -O2 -I/usr/local/include -MT omindex.o -MD -MP -MF ".deps/omindex.Tpo" -c -o omindex.o omindex.cc; \
then mv -f ".deps/omindex.Tpo" ".deps/omindex.Po"; else rm -f ".deps/omindex.Tpo"; exit 1; fi
omindex.cc:97: error: â in namespace â does not name a type
omindex.cc: In function â:
omindex.cc:460: error: â was not declared in this scope
omindex.cc: In function â:
omindex.cc:836: error: â was not declared in this scope
make[1]: *** [omindex.o] Error 1
make[1]: Leaving directory `/home/volsunan/try/xapian-omega-1.0.1'
make: *** [all] Error 2

$ sed -n '97p' omindex.cc | hexdump -C
00000000  73 74 61 74 69 63 20 58  61 70 69 61 6e 3a 3a 54  |static Xapian::T|
00000010  65 72 6d 47 65 6e 65 72  61 74 6f 72 20 69 6e 64  |ermGenerator ind|
00000020  65 78 65 72 3b 0a                                 |exer;.|

$ echo $LANG

> Compiling on one Linux distro and running on another is something of a
> minefield, and often worse for C++.  It might be worth installing
> "CentOS 4.4" (which is what the CF shell server seems to be running) and
> using that to build.  If you use virtualisation software (KVM or
> similar) you can run it on top of your normal distro.

Just FYI, my research reveals that SF shell runs on CentOS release 4.4,
but it web server runs on Fedora Core 2. 

Hope the info may come handy when you try to build an official binary code
for SF.


Tong (remove underscore(s) to reply)

More information about the Xapian-discuss mailing list